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Basics

Main window

This section is a brief summary of Maya’s main interface. As you read, keep in mind the
following:

You can show or hide any of the UI elements in the main window using the Display > UI 
Elements menu.

You can also hide a UI element by clicking the hide button to the left  of or above 
the UI element. To show a UI element, press  on another hide button and select the 
desired UI element from the pop-up menu.

You can hide all the interface elements and instead use Maya’s quick command
features: the Hotbox, Marking Menus, and hotkeys.

A menu icon  appears to the right of the mouse pointer when a right mouse button 
pop-up menu is available for the control over which the mouse is hovering.

Status line (toolbar)

The status line (or toolbar) lets you

Change the menu set

Access common functions
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Control the selection mask

Set various options

Change the contents of the sidebar.

Related topics

Shelves

Display > UI Elements

  Quick layout buttons

  Status line (toolbar)

  Command line

  Attribute Editor

  Channel Box

 



Menus and menu sets file:///C:/Program%20Files/Autodesk/Maya8.5/docs/Maya8.5/en_US/Ge...

1 of 2 1/25/2009 8:07 PM

Basics

Menus and menu sets

The menus in Maya are grouped into menu sets. Each menu set corresponds to a module of 
the software: Animation, Polygons, Surfaces, Dynamics, and Rendering. Maya Unlimited has 
additional modules. As you switch between menu sets, the right-hand menus change, but the 
left-hand menus remain the same; these are the common menus.

To switch between menu sets, use the Status Line drop-down list or hotkeys. The default 
hotkeys are: F2 (Animation), F3 (Polygons), F4 (Surfaces), F6 (Rendering).

You can create custom menu sets that contain your choice of menu items. For more 
information, seeCustom menu sets.

Tear-off menus

You can display menus as separate windows. This is helpful when you use a menu repeatedly. 
Pull down the menu and click the tear-off line at the top. Tear-off menus always display on
top.

Related topics

Marking menus

Select tools and actions
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Basics

View hotkeys

Hold + drag Function

 + Tumble

 + Track

 + 

or

 + 

Dolly

Press Function

a Show all

f Show selected

Press Function

1 Rough display

2 Medium display

3 Smooth display

Press Function

4 Wireframe display

5 Shaded display
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6 Shaded and textured display

7 Display with lights

+ Switches between the standard view and a full-screen view

+B Changes the background color of the perspective and orthographic 
panels: standard (light gray), dark gray, or black

Related topics

Create or edit a marking menu

  Assign a predefined command to a hotkey

  View a list of all assigned hotkeys
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Center the view on selected or all objects

To... Do this

Show the selected objects In the panel menus select View > Frame 
selected or press F.

Show all objects In the panel menus select View > Frame 
all.

Point the camera at the selected objects but
don’t move the camera.

In the panel menus select View > Look 
at selection.

Related topics

Return to previous views

  Show or hide objects
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Lock a manipulator to the current selection

Select the object or objects.1.

Select the Move, Rotate, Scale, or Show Manipulator Tool.2.

Click the Lock current selection icon in the Status Line (toolbar).3.

While the lock icon is on, you cannot select other objects using this tool. Clicking or 
dragging  operates the active manipulator handle (like  does normally).

Click the Lock current selection icon again to unlock the manipulator.
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Getting Started with Maya
> Maya Basics

>  Lesson 3:  Viewing the Maya 3D scene

Camera tools

In the lessons so far, when you looked at an object from the top, front, or side views you have
been viewing the scene through an orthographic view. Orthographic views appear 
two-dimensional because the object is displayed using parallel projections of only two axes at 
a time. (Scooter images courtesy of The Art of Maya)

When you view the scene through the perspective view, you are viewing the scene in a
three-dimensional manner. The perspective view simulates what your scene would look like
from a camera’s point of view.

In Maya, you view the scene through a set of virtual cameras. These cameras are either 
orthographic or perspective in nature. You can adjust how these cameras view the scene using
the Camera Tools.

The three primary methods for manipulating the camera view are dolly, tumble, and track.

Dolly Tool

The Dolly Tool gets its name from filmmaking where a camera, mounted on a wheeled tripod, 
is moved towards or away from the scene. In Maya, dollying allows you to view the items in 
your scene either close up or from further back.

To dolly the perspective view

Enlarge the scene view to a single perspective view.1.
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Do one of the following:2.

(Windows & Linux) Press the Alt key and drag the mouse to the right while 
holding down the right button on your mouse.

(Mac OS X) Press the Option key and drag the mouse to the right while holding 
down the right button on your mouse.

To dolly the camera outwards from the subject in the scene you can perform the same 
key and mouse combinations as described above but drag the mouse to the left.

3.

Dolly works in both the perspective and orthographic views.

Tip
If you make an error when adjusting your camera view of the scene, you can reset the 
camera to its default home setting.
To reset the camera view for a particular orthographic or perspective view:
From the panel menu, select View > Default Home.

Tumble Tool

The Tumble Tool allows you to tumble or rotate the camera’s view around a particular center
of interest to achieve either a higher or lower vantage point, or a different side angle.

To tumble the perspective view

Press the Alt key (Windows & Linux) or the Option key (Mac OS X) and drag the mouse 
either left or right, or up or down, while holding down the left button on your mouse.

Tumbling the view revolves the camera around the center of the scene view, in 
whichever direction you drag (left, right, up or down). The Tumble Tool does not work in
the orthographic views.

Track Tool
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The Track Tool allows you to move the camera up, down, or sideways in relation to the scene.

To track the perspective view

Press the Alt key (Windows & Linux) or the Option key (Mac OS X) and drag the mouse 
in any direction, while holding down the middle button on your mouse.

The Tracking Tool works for both orthographic and perspective views.

Note
Even though the objects appear to move across the screen when operating any of the 
camera tools, it is the viewing camera that is actually moved in relation to the scene, not 
the objects.
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3D coordinates

The most basic visual entity is the point. The point has no size, but it has a location.

To determine the location of points, we first establish an arbitrary point in space as the origin.

We can then say a point’s location is so many units left (or right) of the origin, so many units
up (or down) from the origin, and so many units higher (or lower) than the origin.

These three numbers give us the 3D coordinates of the point in space. For example, a point 7 
units right (x), 4 units down (z), and 3 units above (y) the origin has the XYZ coordinates 
(7,4,3).

To specify points on the opposite side of the origin, we use negative numbers. In the example,
a point at (-5, -2, -1) would be 5 units left of the origin, 2 units up, and 1 unit below.

In computer graphics, we don’t really say the point is “left/right”, “up/down”, or
“higher/lower”. Instead we call the three dimensions the X axis, the Z axis, and the Y axis.

Y-up and Z-up

In animation and visual effects, the tradition is to use Y as the “up” or elevation axis, with X
and Z as the “ground” axes. However, some other industries traditionally use Z as the up axis
and X and Y as the ground axes.

Maya lets you switch the up axis between Y and Z. Select Windows > Settings/Preferences > 
Preferences, then click Settings in the list on the left.

Switch between Y-up and Z-up
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Polygonal Modeling

Introduction to polygons

Polygons are a type of geometry you can use to create three-dimensional models in
Autodesk® Maya®. The other geometry types that Maya provides for modeling in 3D are
NURBS and subdivision surfaces.

Polygons are useful for constructing many types of 3D models and are widely used in the 
development of 3D content for animated effects in film, interactive video games, and the 
internet.

Polygon terminology

Polygons are straight-sided shapes (3 or more sides), defined by three-dimensional points 
(vertices) and the straight lines that connect them (edges). The interior region of the polygon 
is called the face. Vertices, edges, and faces are the basic components of polygons. You select
and modify polygons using these basic components.

When you model with polygons you usually use three-sided polygons called triangles or 
four-sided polygons called quadrilaterals (quads). Maya also supports the creation of polygons
with more than four sides (n-gons) but they are not as commonly used for modeling.

An individual polygon is commonly called a face, and is defined as the area bounded by three 
or more vertices and their associated edges. When many faces are connected together they 
create a network of faces called a polygon mesh (also referred to as a polyset or a polygonal 
object). You create your 3D polygonal models using polygon meshes. Polygon meshes can be 
created using a variety of techniques. For more information on these techniques see Polygon 
modeling overview.

Polygon meshes normally share the vertices and edges that are common between the 
individual faces. These are referred to as shared vertices or shared edges.

A polygon mesh can also be composed of several disjointed sets of connected polygons called 
shells. The outside edges of a mesh or shell are referred to as border edges.

Texture mapping polygonal models

Polygon models are texture mapped using UV texture coordinates. For more information on 
texturing polygonal models see Introduction to UV mapping.

Related topics

Polygon modeling overview

  Introduction to UV mapping
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Basics

Move, rotate, or scale objects and components

For details of how to move, rotate, and scale with the Universal Manipulator, see Use the 
Universal Manipulator.

To move objects or components

Select the object or component.1.

Select the Move Tool or press w.2.

Use the position manipulator to change the position of the selected objects.3.

Hold w and press  to show a marking menu of options and actions related to the Move
Tool.

To rotate objects or components

Select the object or component.1.

Select the Rotate Tool or press e.2.

Use the rotation manipulator to rotate the selected objects. The selection rotates around
the pivot of the key object.

3.

Hold e and press  to show a marking menu of options and actions related to the 
Rotate Tool.

To scale objects or components

Select the object or component.1.

Select the Scale Tool or press r.2.

Use the scale manipulator to scale the selected objects. The selection scales from the 
pivot of the key object.

3.

Hold r and press  to show a marking menu of options and actions related to the Scale
Tool.

To use the combined Move/Rotate/Scale Tool

This tool shows the move, rotate, and scale handles all in one manipulator. You may find it
easier to use than the individual tools when you’re performing a lot of move, rotate, and scale
operations on an object to get it into position.

Select Modify > Transformation Tools > Move/Rotate/Scale Tool.

To type exact transformation values

Select the object or component.1.

Select the Move, Rotate, or Scale Tools.2.

From the drop-down menu for the Input box, select either Absolute transform or 
Relative transform.

3.
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Click the input field and type X, Y, and Z values in the appropriate fields.4.

Note
If you are moving a selected NURBS object to an extreme distance or scaling an NURBS 
object to an extreme size, you may need to activate the High Precision NURBS display to 
view the objects correctly. The High Precision NURBS display setting can be found in 
Window > Settings/Preferences > Preferences in the NURBS category under the heading 
Display.

Related topics

Transformations

Use manipulators

 Move, rotate or scale components proportionally

 Change the pivot point

 Flip objects

 Transform along different axes

Modify > Transformation Tools > Move Tool, Rotate Tool, Scale Tool, Show
Manipulator Tool

 Input box
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Basics

Return to previous views

To... Do this

Go back in the view 
history.

In a panel, select View > Previous or press [.

Go forward in the view 
history.

In a panel, select View > Next or press ].

Bookmark the current 
view.

In the panel menus select View > Bookmarks > Edit 
bookmarks.

Click New bookmark.

Change the name of the bookmark to something 
descriptive.

Return to a bookmarked 
view.

In the panel menus select View > Bookmarks and then 
click the name of the bookmark.

Create a shelf button for a 
bookmark

In the panel menus select View > Bookmarks > Edit 
bookmarks.

Click the bookmark.

Click Add to shelf.

Related topics

Tumble, track, dolly, or tilt the view

  Center the view on selected or all objects
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Select actions on a shelf

Click an icon on the shelf to perform the action.

Click a tab above the icons to show a different shelf.

Use the pull down menu to the left of the icons (the black arrow) to show or hide the 
tabs.

If the tabs are hidden, or if there are too many to fit on screen, click the tab icon to the 
left of the icons to show a menu of available shelves.

Drag menu items or snippets of code onto a shelf with .
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Getting Started with Maya
> Animation

>  Lesson 1:  Keyframes and the Graph Editor

Introduction

When you set a keyframe (or key), you assign a value to an object’s attribute (for example,
translate, rotate, scale, color, etc.) at a specific time.

Most animation systems use the frame as the basic unit of measurement because each frame 
is played back in rapid succession to provide the illusion of motion.

The frame rate (frames per second) that is used to play back an animation is based on the 
medium that the animation will be played back (for example, film, TV, video game, etc.)

When you set several keys at different times with different values, Maya generates the 
attribute values between those times as the scene plays back each frame. The result is the 
movement or change over time of those objects and attributes.

In this lesson, you will use simple keyframing techniques to make a ball fly over a fence and 
bounce off the ground.

In this lesson, you learn how to:

Set keyframes for animatable objects and their attributes.

Use the Time and Range slider and Playback Controls to control the playback.

Use keyboard shortcuts to set keyframes.

Use the Graph Editor to view animation curves.

Modify the animation of objects using the Graph Editor.

Set preferences to increase the playback quality.

 Keyframe.mov
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Getting Started with Maya
> Animation

>  Lesson 1:  Keyframes and the Graph Editor

Setting keyframes

In the following steps, you use keyframes to set the starting and ending positions of the ball’s
movement.

To set beginning and ending keyframes

Click the rewind button to go to the start of the playback range. This changes the 
current frame to 1.

1.

Select the ball, then select Animate > Set Key. (Keyboard shortcut: s).2.

This sets a key at frame 1 for all transform attributes of the ball. Transform attributes 
are the X, Y, Z move attributes. Although you animate only the translate X and Y 
attributes of the ball in this lesson, keying all transform attributes saves you time 
having to choose specific attributes to be keyed.

In the Time Slider, notice the red marker at frame 1, known as a tick. This tick
appeared when you set the key for frame 1. With the ball selected, ticks in the Time
Slider indicate where you’ve set keys.

Go to frame 72. A convenient way to do this is to click the desired position in the Time 
Slider.

3.

With the Move Tool, drag the ball’s X-axis handle to position the ball at the right edge of
the ground as shown in the image below.

4.

Set a key at frame 72. (Press s.)5.

Go to the start time and play the animation.6.

From the two keys you’ve set, Maya creates motion between the positions. By default,
the animation plays in a loop from frame 1 to 72. The ball travels through the fence at
this stage.

Press the Stop button on the playback control to stop the animation after you view a 
few repetitions. 

7.

You can drag the mouse back and forth (scrub) in the Time Slider to see the animation 
play back and forth at the speed you drag the mouse.

If you were to display the scene with Panels > Layouts > Four Panes, only the active
panel would show the ball moving.

To make the ball fly over the fence rather than pass through it, you need to position the ball 
above the fence and set a key there.

To set intermediate keyframes
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Go to frame 33 or so—at the moment where the ball sits in the middle of the fence.1.

With the Move tool, drag the Y-axis handle of the ball until it sits slightly above the 
fence.

2.

Tip
Throughout this lesson, tumble the perspective view or examine a front view to make 
sure the positioning is correct.

Set a key. (Press s.)3.

Play the animation.4.

The ball now flies off the ground, over the fence, and back to the ground in a smooth 
arc between the keyed start, middle, and end positions.

Press the stop button to end the playback. 5.

In subsequent steps, play the animation after each key you set. It’s generally useful to
check your work in progress after each key, especially when you are learning.

In the next steps, you’ll set keys to bounce the ball in the middle of the right half of the
ground.

To set keyframes to make the ball bounce

Go to frame 50. At this moment, the ball sits in a position above the middle section of 
the right half of the ground.

1.

Move the ball so it sits on the ground.2.

Set a key.3.

Go to frame 60.4.

Move the ball up again, but not as high as its peak height above the fence.5.

Set a key. When you play the animation, the ball travels over the fence and bounces on 6.
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the other side. 

If you have a fast computer, you might notice that the animation plays too fast. By 
default, Maya plays the animation as fast as it can be processed. Because this scene is 
simple, the animation might play faster than the default film rate (24 frames per
second).

Do not be concerned that the animation plays with a halting or jerky motion. When you 
render all the frames of your animation for final production, the animation will be 
smooth. If you want to preview the animation at the smooth production speed (or 
nearly so), use Window > Playblast.
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Getting Started with Maya
> Animation

>  Lesson 1:  Keyframes and the Graph Editor

Deleting extra keyframes and static channels

As you set keys, you often create many unintended keys. For example, when you used the Set
Key operation on the ball, Maya created keys on all transform node attributes of the ball, for 
instance Rotate Z, not just the intended Translate X and Translate Y attributes. The curves 
representing such attributes have unchanging values. The attributes are known as static 
channels.

You can identify static channels by examining animation curves in the Graph Editor. If a curve
is horizontally flat its whole length, the value of the attribute it represents isn’t changing. The
attribute is a static channel. Static channels slow Maya processing, so it’s beneficial to remove
them in complex scenes.

To delete static channels

From the main menu, select Edit > Delete All by Type > Static Channels.1.

This deletes all unnecessary keys for all objects in the scene. Alternatively, you can remove 
the static channels for a selected object with Edit > Delete by Type > Static Channels.

In addition to static channels, you’ll often create excess keys—keys that aren’t being used to
control the shape of a curve. Whenever you see three key points that lie in a straight line, the
one in the middle is unnecessary. For example, in this lesson’s original Translate X curve,
there were four redundant keys:

When you remove redundant key points, the shape of the curve doesn’t change and you
speed up Maya processing.
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Getting Started with Maya
> Animation

>  Lesson 1:  Keyframes and the Graph Editor

Setting the playback range

In this lesson, you work with a scene we’ve created for your use. In the following steps, you
open the scene and set how long the animation will play.

To open the scene

Make sure you’ve done the steps in Preparing for the lessons.1.

Open the scene named Keyframing.mb. 2.

You can open the scene named Keyframing.mb from the Maya DVD or from the drive 
where you copied the Getting Started with Maya data files.

The scene contains a ball object that is currently positioned on the X-axis near the edge 
of a ground plane.

To set the playback range for the scene

To animate the ball, you key its position at different times of the playback range.

The playback range is defined by the Time and Range slider. The Time and Range slider 
controls allow you to playback or scroll through your animation or move to a specific 
point in time of your animation so you can set keyframes.

Look over the playback controls, as shown in the figure below:1.

The Time Slider displays the playback range and keys you’ve set for a selected object.
Keys are displayed as red lines. The box at the right of the Time Slider lets you set the
current frame (time) of the animation.

The Playback Controls control animation playback. You may recognize the conventional 
buttons for play and rewind (return to the start time). The stop button appears only 
when the animation is playing. To find out which operation a button represents, hold the
mouse pointer over it.

The Animation Preferences button displays a window for setting animation preference 
settings such as the playback speed.

The Range Slider controls the range of frames that play when you click the play button.

The above items will have more relevance as you work through this lesson. After you 
complete this lesson, experiment with these items to learn more what they do.

The playback range is currently set at a range of 1 to 24. At a default playback rate of
24 frames per second, the scene can play for one second. Because you’ll animate the
ball for a few more seconds than this, you need to lengthen the playback range.
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In the Playback End Time box (see above), enter 72. 2.

A frame rate of 24 frames per second (fps) is the frame rate used for motion picture 
film. For video, the frame rate can be 30 fps (NTSC) or 25 fps (PAL) depending on the 
format being used.

With a playback range of 1 to 72, you’ll be able to create three seconds of animation.
(72 frames divided by 24 frames per second = 3 seconds.) This is enough time for the
short animation you’ll create in this lesson.
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Getting Started with Maya
> Animation

>  Lesson 1:  Keyframes and the Graph Editor

Using the Graph Editor

For a more convincing animation, you need to bounce the ball more sharply off the ground
and speed up the ball’s horizontal movement. You’ll use the Graph Editor to make both 
modifications.

The Graph Editor is an editor that graphically represents the various animated attributes in 
your scene. The animated attributes are represented by curves called animation curves. You 
edit animation curves in the Graph Editor.

To edit animation curves using the Graph Editor

With the ball selected, select Window > Animation Editors > Graph Editor.1.

The Graph Editor displays several animation curves, one for each keyed attribute of the 
ball. The animatable attributes for the ball are listed in the left column. Specifically, it 
displays the attributes of the selected transform node of the ball.

Each curve graphs how an attribute changes value during the animation. The column of
numbers at the left represents attribute values that can be animated, while the row of
numbers at the bottom represents time (frame) values. At each point on the curve, you
can see the value of an attribute at a particular time. The small black squares on the
curves represent points where you’ve set keys.

Shift-Select only the Translate X and Translate Y attributes in the left column of the 
Graph Editor.

2.

Now only the animation curves for Translate X and Translate Y appear in the Graph
Editor.

This simplifies the display. With too many curves present, it’s hard to see specific
curves. When you use the Graph Editor, you usually focus on one or a few curves.

To center the display of the animation curves, select View > Frame Selection (in the
Graph Editor window). If you want to see more detail in the graph, use your mouse to 
dolly and track the graph view.

3.
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The green curve represents Translate Y, while the red represents Translate X. The color 
of each curve matches its attribute name. This color scheme is consistent throughout 
Maya for X, Y, and Z (red, green, blue) so is easy to remember.

If you’ve never used a graph editor before, the relationship between a curve’s shape
and the animation it represents might be hard to understand. With experience, you’ll
quickly recognize how curve shape affects animation.

In the above graph, the straight curve of Translate X indicates that the ball moves 
horizontally across the ground at a constant rate over time.

The wavy curve of Translate Y indicates that the ball increases its height steadily until 
frame 33, dips more quickly until frame 50, then rises and dips again until frame 72.

When the ball first bounces off the ground at frame 50, it seems to float and slip rather 
than rebound. The shape of the Translate Y curve illustrates why. Near frame 60, the 
curve is soft and rounded. The Translate Y values gradually decrease to the low point 
then gradually increase. The transition from decreasing to increasing values is smooth.

The Graph Editor’s usefulness lies in the fact that you can edit the shape of the
animation curves to edit the animation of any keyed attribute. To create a sharp
bounce, you can edit the curve so that the transition from decreasing to increasing
values is abrupt at frame 50. Specifically, you’ll create a corner at that key point rather
than a rounded curve.

Select the point on the Translate Y (green) curve at frame 50. This causes a pair of 
tangent handles to appear at the point. Each end point of the newly displayed straight 
line is a tangent handle. The handles let you control the curvature near the key point.

4.

Animation curves have a few control structures for curve editing. You can do any of 
these operations:

Use the Move tool and middle mouse button to move a key point. You can alternatively
use your keyboard to enter precise values for a selected key’s frame and value in the
boxes above the graph area.

Use the Move tool and middle mouse button to drag the tangent handles and change 
the adjacent curvature. 

(You can shift-drag with the Move tool to constrain a move operation to a single 
direction.)

Use the Scale tool and middle mouse button to scale selected key points closer together
or further apart.

Use the Graph Editor’s Tangent menu items to change the adjacent curvature. This is
the operation you’ll use in the next step.

In the Graph Editor, select Tangents > Linear.5.

This changes the curvature around the key point from rounded to cornered. Specifically,
the setting you select specifies how the key point tangent handles lie at this key point. 
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This affects the type of interpolation between key points.

Play the animation and you’ll see the ball bounce more sharply.6.

To sharpen the bounce more, you need to edit the positioning of the tangent handles to 
steepen the curvature approaching the key point.

Select one of the tangent handles.7.

Use the Move Tool and the middle mouse button to drag it upwards a little so you can 
see the how the curvature at the key point changes.

8.

By default, when a pair of tangent handles share a key point, they work as a unit. Move 
one and you move the other in an opposing direction. This is often desirable in an 
animation curve, because it ensures the curvature at that point stays symmetrical. 
Symmetrical curvature often helps prevent unusual animation shifts.

In this case, however, you want to steepen the curvature’s approach toward the curve
point in the same direction on both sides. You therefore need to break the symmetrical
interdependency between the two tangents.

Undo your previous move of the tangent handle.9.

Select the key point at frame 50 (not a tangent handle).10.

In the Graph Editor, select Keys > Break Tangents.11.

This lets you move each tangent handle independently.

Select the right tangent handle and use the Move Tool to move it up a little. Do the 
same for the left tangent handle. Be careful not to select the key point.

12.

This sharpens the bounce to simulate the effect of gravity and elasticity.
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Getting Started with Maya
> Animation

>  Lesson 1:  Keyframes and the Graph Editor

Changing the timing of an attribute

The ball seems to move too slowly in its journey. In the following steps, you’ll use the Graph
Editor to hasten its movement. Specifically, you’ll cause the ball’s animation to finish its
journey in two seconds (48 frames) rather than three (72 frames).

To speed up the animation of the ball’s movement

Drag a selection box around all key points of both curves. 1.

Select the Scale tool.2.

Click and hold the middle mouse button anywhere in the graph at frame 1 (slightly to 
the right of 0).

3.

Notice the question mark icon. The location of this icon indicates the point from which 
scaling occurs. (Because you need to scale the animation inward toward frame 1, you 
need to start your drag operation at frame 1.)

Without releasing the mouse button, drag to the left until the right-most key points on 
both curves are positioned roughly at frame 48. (When selected, the right-most key 
points are yellow.)

4.

This scales the curves symmetrically towards frame 1. The animation of the ball now 
plays from frame 1 to 48 rather than 1 to 72. The ball traverses the scene in less time, 
which, of course, means it moves faster.

If you had started your drag operation from the middle of the frame range, the scale 
operation would have pulled the curves toward the middle of the frame range. You can 
snap the keypoints to whole values to keep the keyframes on a consistent timing.

Widen the Graph Editor window as necessary to see the graph clearly. Also, dolly the 
view or select View > Frame Selection (in the Graph Editor window).

5.
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Basics

Change the pivot point

To move the selected object’s pivot

Select a transformation tool such as the Move Tool, Rotate Tool, or Scale Tool.1.

Press the Insert or Home key to switch the manipulator to pivot point mode.2.

Use the manipulator to move the pivot point.3.

Press Insert or Home again to switch the manipulator back to normal mode.4.

To move the pivot point using exact values

Show the Attribute Editor and click the transform node’s tab.1.

In the Pivots section, turn on the pivot display options so you can see the effects of 
editing the pivot values.

2.

Do one of the following:3.

In the Local Space section, type X, Y, and Z coordinates for the Rotate Pivot and
Scale Pivot relative to the object’s origin.

In the World Space section, type X, Y, and Z coordinates for the Rotate Pivot and 
Scale Pivot relative to the world origin.

To reset the selected object’s pivots to center

Select the Rotate or Scale Tool.1.

Select Modify > Center Pivot.2.

To make the selected object’s pivot points visible in the scene

Select Display > Component Display > Rotate Pivots and Display > Component Display 
> Scale Pivots.

To keep the pivot in place while working with components

When you transform components, Maya creates a temporary pivot at the center of the 
selected components. Because the pivot is always at the center of the selection, selecting or 
deselecting additional components moves the pivot.

You can lock the pivot in place so it won’t move as components are added to or removed from
the selection.

Press the Insert or Home key to show the pivot point manipulator.1.

Move the pivot point.2.

Click the circle at the top of the pivot point manipulator to lock or unlock the pivot point 
for component transformations. When the circle is filled, the pivot is locked.

3.

Note
If the pivot point of an object is changed from its default value, duplicating multiple 
copies of that object results in additional transforms to the channels of the duplicated 
transform node. However, the resulting position, orientation and the pivots of the 
duplicated objects will be correct. To avoid these extra transforms, the duplicate 
command should be invoked with No of copies set to 1. The hotkey g can then be used as 
many times as needed.
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Related topics

Transformations

  The pivot point

Modify > Center Pivot
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Getting Started with Maya
> Rendering

>  Lesson 1:  Rendering a scene

Batch rendering a sequence of animation 
frames

After you model, animate, and color your scene, you set several Render Settings options and 
then use the software renderer to batch render part or all of the animation’s range of frames
to files on disk. Each file represents a single frame (image) of the animation.

To set the Render Settings for batch rendering

In the Render View window, select Options > Render Settings to display the Render
Settings window.

1.

In the Render Settings window, select the Common tab, and then open the Image File 
Output section.

2.

In the Image File Output section, set the following options:3.

File Name Prefix: Type the name Apple. This name will be the base of the 
filenames created by batch rendering. 

Frame/Animation Ext: Select name.#.ext. This specifies that the filenames will 
have the format prefix.frameNumber.fileFormat. For example, batch rendering the
entire 200-frame animation will create Apple.0001.iff, Apple.0002.iff, and so 
on through Apple.00200.iff.

Image Format: Select Maya IFF (.iff), Maya’s standard image file format. You
can use the .iff format for any further work you need to do, including previewing
and compositing the animation. If you require a different format, you can specify 
it instead of .iff in the Render Settings.

Start frame: Enter 1, the first frame of the animation sequence to be batch 
rendered.

End frame: Enter 50, the last frame to be batch rendered. (Rendering all 200 
frames may be time-consuming.)

Frame padding: Enter 4. This causes the frameNumber part of the filenames to 
be four digits prefixed with 0s. For example, the filenames will be 
Apple.0001.iff through Apple.0050.iff. 

Camera: Select apple_camera from the drop-down list to indicate which camera 
view to render.

The four-digit padded filename is compatible with many image playback programs, for
example, Maya’s FCheck utility. Image playback programs let you view rendered
animation sequences on your monitor at real-time speed.

For the remaining options in the Render Settings window, you’ll use the default settings.
Maya will render using the camera (persp), image size (640x480), and anti-aliasing
quality (Production Quality) that you specified earlier in the lesson.

After you set the Render Settings, the top portion of the Common tab shows the correct 
path and filenames for the files to be created during batch rendering. Check that this 
information is correct.
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Close the Render Settings window.4.

To batch render animation frames

Save the scene.1.

It’s a good practice to save the scene before batch rendering. This is useful if, after
batch rendering, you need to change any display settings and render again. By saving
the scene prior to batch rendering, you can examine the scene to learn which option
settings were in effect at the time you batch rendered.

From the Rendering menu set, select Render > Batch Render > .2.

The Batch Render Frame window appears.

Turn on Use all available processors, then click Batch Render and close the option 
window to start batch rendering. 

3.

(The Use all available processors option allows Maya to use all the processors available 
on the local machine to complete the render.)

Note
For users of Maya Personal Learning Edition, the Use all Available Processors option is 
disabled. Use the default settings.

Batch rendering 50 frames of a simple scene takes a few minutes. A complex scene may
take hours per frame, depending on the speed of your computer.

To check the status of the batch render

While Maya is rendering, select Window > General Editors > Script Editor. Expand the
size of the Script Editor window. The window shows a completion log for the frames 
being rendered. 

1.

Maya puts the resulting files in a default images directory. The files have the following 
names:

Apple.0001.iff

Apple.0002.iff

Apple.0003.iff

...

...

Apple.0050.iff

The images directory is located in the same path as the scenes directory. You can have 
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Maya save to a different path by changing the project setting. See the Maya Help for 
further information on projects.

Close the Script Editor when the following message appears:2.

// Result: Rendering Completed. See mayaRenderLog.txt for information. //

The mayaRenderLog.txt file contains rendering statistics for advanced users.
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Getting Started with Maya
> Rendering

>  Lesson 1:  Rendering a scene

Rendering using the Maya software renderer

You are nearly ready to render the entire animation to disk. You must first switch camera
views so you can render the scene from the point of view of the camera that was animated for
this lesson. When animating a camera it’s a good practice to create a second camera to
animate, rather than animating the default persp camera. In that way you can return to the
default perspective view should it become necessary.

Rendering the entire animation can take a lot of time, so it is useful to first use Maya’s
software renderer to test render a few frames to your monitor and examine the results.

Once you are satisfied with the quality of a few rendered frames, you can render the entire 
animation to disk.

To switch camera views and playback the animation

In the perspective view, select Panels > Perspective > apple_camera.1.

The view updates to display the scene as seen through the lens of the apple_camera.

Click the Play button in the Timeslider playback controls.2.

During playback, the animated camera tracks and tumbles about the apple.

Stop the animation at a frame you want to test render.3.

To test render the current frame of animation

In the Render View window, select Options > Render Settings.1.

In the Render Settings window, select Maya Software from the Render Using drop-down
list.

2.

In the Render Settings window, select the Maya Software tab.3.

In the Anti-aliasing Quality section, select Production quality from the Quality 
drop-down list.

4.

This setting provides high quality results by smoothing any jagged surface edges in the 
rendered image.

Close the Render Settings window.5.

In the Render View window, select Render > Render Current Frame (apple_camera).6.

This menu item uses the software renderer to render a single frame of the scene that 
you rendered with IPR previously but from the point of view of the animated
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apple_camera.

You might not see a big improvement in quality as compared to the IPR-rendered 
image. If you dolly the camera closer to the apple and render once with IPR and once 
with the software renderer, you will see an improvement at the edges of the apple as 
shown below:

Go to frame 120 of the animation, where the apple is viewed in a different position.7.

In the Render View, select Render > Render > Current (apple_camera).8.

Ensure that the rendered image looks good at this frame also.

Now that you’ve checked a pair of rendered frames that represent the entire animation, you
are ready to render the entire animation sequence. In your own projects, you might want to
test render several frames, particularly where new shading and lighting elements occur in the
animation.
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Basics

Construction history

As you work in Maya, most of your actions create nodes in the construction history of the
objects you work on. At each point in your work, the current scene is the result of all the
nodes you’ve created so far.

For example, you can revolve a curve around a centerpoint to create a new surface with a 
cross-section in the shape of the curve. When you apply this action to the curve, a new 
revolve node is created. The new node has the shape of the curve as an input. It has 
attributes that control how it creates the surface from the curve. And it has the resulting 
surface as its output.

This chain of nodes, from the curve to the revolve node to the surface, is called the surface’s
construction history. The most important thing about construction history is that you can 
change it. You can reshape the curve, or change the attributes on the revolve node, and the 
resulting surface updates automatically.

Construction history is part of Maya’s dependency graph. While construction history refers to 
the history of actions that created the scene, the entire dependency graph refers to all 
connections (input and output) between nodes.

Related topics

Edit completed commands (construction history)

  Show a custom manipulator for the selected node

Nodes and attributes

  Dependency graph

 



Move, rotate or scale components proportionally file:///C:/Program%20Files/Autodesk/Maya8.5/docs/Maya8.5/en_US/Ge...

1 of 1 1/25/2009 8:19 PM

Basics

Move, rotate or scale components 
proportionally

For details of how to move, rotate, and scale proportionally with the Universal Manipulator, 
see Use the Universal Manipulator.

The Proportional Modification Tool lets you move a manipulator and have the surrounding 
control points follow proportional to their distance from the moving point. This effect is 
controlled by the Distance Cutoff setting.

“Proportional modification” is sometimes shortened to propmod.

To transform the selected components proportionally

Select the components you want to modify. Only the selected components are 
influenced by the tool.

1.

Select Modify > Transformation Tools > Proportional Modification Tool > .2.

Use the options in the Tool Settings panel to control how distance is measured and how 
quickly the influence of the manipulator falls of with distance:

3.

Set the Modification Type to World to calculate distance in world space. Set it to 
Parametric to calculate distance across the surface (Parametric only works on 
NURBS).

Set Modification Falloff to Linear to have influence fall off at a steady rate. Set it 
to Power to have influence fall off very quickly.

Press Insert or Home to change the manipulator to pivot point mode. Drag the 
manipulator to move it where you want the center of influence. Press Insert or Home 
again to change the manipulator back to normal mode.

4.

Use the other handles on the manipulator to move or scale the selected components 
based on their distance from the manipulator.

5.

Related topics

Use manipulators

  Move, rotate, or scale objects and components
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Basics

Move, rotate, or scale components with 
reflection

When editing a model with the transformation tools (Move, rotate, and scale), you often need 
to make changes symmetrically. For example, when modifying a character's head, if changes 
are made to the top of the left ear, you may also want the top of the right ear to also be 
affected. The Reflection setting lets you do this.

You can select a component(s) on one half of the model, and the Reflection setting will 
highlight the affected component(s) on the opposite half of the model with a white color. This 
is called the color feedback.

To move, rotate, or scale components on an object using the Reflection setting

In the scene view, select the components you want to move, rotate or scale on one half 
of the surface mesh.

1.

Select the appropriate transformation tool by doing either of the following:2.

Double-click the desired transformation tool icon on the Toolbar.

Select Modify > Transformation Tools > Move/Rotate/Scale Tool > .

The tool settings for that transformation tool appear.

In the Tool Settings Editor, turn the Reflection setting on.3.

The corresponding component(s) across the reflection axis is highlighted in white.

When you subsequently move, rotate, or scale the selected component(s), the 
corresponding highlighted component(s) are also transformed on the opposite side of 
the reflection axis.

4.

With the other reflection settings you can specify:5.

whether the Center of reflection is at the origin or based on the bounding box of 
the object. 

set the Tolerance for the reflection (that is, how closely the selected component 
and the component across the reflection axis have to mirror each other in order 
for mirroring movement to occur). 

the Reflection axis which the reflection occurs across.

The manipulator indicates the axis along which the reflection takes place:
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Note
The position of the reflection plane on the manipulator doesn’t correspond to the actual
origin of reflection (which may be outside of the current view); it’s just a visual indication
of the reflection plane (x, y, or z).

Notes on the using the Reflection setting

The reflection color feedback automatically appears whenever the reflection setting is 
turned on and cannot be optionally turned off. The color feedback will not display if you 
momentarily edit an attribute in the Channel Box. The reflection color feedback will 
automatically update whenever the reflection center, axis, or tolerances are changed.

The reflection color feedback only appears on NURBS surfaces when the surface is 
displayed in shaded mode. When textures are applied to the shading material on a 
NURBS surface they will temporarily not display on the surface while the transformation 
tool with reflection settings are in use.

Reflection color feedback does not appear on subdivision surfaces.

The Reflection color feedback indicates the components affected by the current 
selection. In some cases, components may or may not appear with color feedback 
based on the original component selection, reflection center, axis, or tolerances. For 
example, when the Center setting is set to Bounding box, when the object shape is 
irregular, there may not be a corresponding component to highlight based on the shape 
of the bounding box. In this situation you should try setting the Center setting to Origin, 
and set the Move setting to either Local or Object space.

Related topics

Move Tool

  Rotate Tool

  Scale Tool
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Basics

Select objects or components

Selecting specific component types

The following table has tips for selecting certain types of components. They follow the same 
general pattern for selecting components, but demonstrate some selection techniques or 
component types that may not be obvious.

To... Do this

Select polygon faces. Press  on a polyset and select Face, or press F11.

Select the dots in the center of the faces.

Select an arbitrary point 
on a curve.

Press  on a curve and select Curve Point.

Press  on the curve and drag to select a point along the 
curve.

Select an isoparm on a 
surface.

Press  on a surface and select Isoparm.

Press  on a visible isoparm that runs in the direction you 
want, then drag to the position you want.

Select an arbitrary point 
on a surface.

Press  on a surface and select Surface Point.

Press  on an isoparm and drag to select a point on the 
surface.

Select a NURBS surface 
patch.

Press  on a NURBS surface and select Surface Patch.
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Select the dots in the center of the patches.

Related topics

Selection, tools, and actions

Edit > Select All

  Edit > Select All by Type
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Select only certain types of objects or 
components (selection masks)

You can limit the types of objects or components Maya selects when you click or drag with the
selection tools. This lets you work on certain parts of a complex model without accidentally 
selecting other objects.

To limit selections, you select which types of objects or components you can and can’t select.
This is called the selection mask.

To... Do this...

Switch between selecting objects 
and components.

Use the Select by object type and the Select by 
component type icons in the Status Line (toolbar).

The icons available in the selection mask depend 
on whether you are in object or component 
selection mode.

Turn a object/component type on 
or off in the selection mask.

Click the type icon in the selection mask area of 
the Status Line (toolbar).

When an icon is depressed, that type is selectable.

Set the selection mask to all 
types.

Press the left mouse button on the pop-up menu 
icon to the left of the selection mask and select All 
Objects/Components On.

Clear the selection mask. Press the left mouse button on the pop-up menu 
icon to the left of the selection mask and select All 
Objects/Components Off.

When all types are off, you cannot select anything. 
Make sure to turn at least one type on again if you 
want to select.

Set the selection mask to a 
preset combination of objects 
and components based on 
workflow.

If the area to the left of the selection mode icons 
on the Status Line (toolbar) is hidden, click the bar 
to expand it.

Press the left mouse button on the pop-up menu 
icon and select a workflow. The selection mask is 
set to objects and components related to that 
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workflow.

Related topics

Select objects or components

Status line (toolbar)
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Getting Started with Maya
> Maya Basics

>  Lesson 3:  Viewing the Maya 3D scene

Selection modes and masks

It isn’t always efficient to have the Hypergraph window open when you want to select an
object at a particular level within its hierarchy. Maya allows you to select items in different
selection modes depending upon your specific needs.

There are three main types of selection modes: Hierarchy, Object and Component. You use 
these modes in order to mask or limit the selection of other objects in order to select only the
types of items you want. When you use a selection mask you are filtering out or masking
items you don’t want to be chosen as part of the selection.

The icons for the three modes appear on the Status Line.

When you first start Maya, the default selection mode is set to Objects. This is useful for much
of your selection work with Maya, with a few exceptions. When you want to select items that 
have been grouped, set the selection mode to Hierarchy.

Tip
If you set the selection mask, it will remain that way until you change it again. If an item
won’t select for you in Maya, you should check the selection mask setting to see if it is set
correctly.

To use the Hierarchy and Combinations selection mask

On the Status Line, choose the Select by Hierarchy and Combinations icon1.

The Selection Mask icons update to display the three selection choices.

On the Status Line, choose the Select by hierarchy icon.2.

Select by hierarchy ensures that when you select items they are selected at their parent
or root node.

In the scene view, shift-click Column and Column1 so they are selected simultaneously. 
(Do not be concerned that they highlight in different colors.)

3.
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Basics

Shelves

Shelves hold commonly used actions and tools, allowing them to be accessed by clicking an 
icon. You can also put custom scripts and panel layouts on a shelf.

Related topics

Select actions on a shelf

  Create, rename, rearrange, or delete a shelf

  Add a tool, action, or MEL script to a shelf

  Edit the MEL script associated with a shelf item

  Edit the contents of a shelf

  Use a custom name or icon for a shelf item

  Change the display of shelves
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Basics

Show or hide objects

To... Do this

Hide the selected objects. Select Display > Hide > Hide Selection.

Redisplay the last object(s) you hid. Select Display > Show > Show Last Hidden.

Show all hidden objects. Select Display > Show > All.

Hide or show all objects of a specific 
type.

To change the display of all panels, use the 
items in the Display > Hide and Display > 
Show submenus.

To change the display of one panel, use the
items in the panel’s Show menu.

Show a specific hidden object. Select the object’s node in one of the editors
and select Display > Show > Show Selection.

Select a hidden object. Use the Outliner or Hypergraph to select the
object’s node.

Hide the actual geometry of an object 
while leaving other components 
visible.

Select Display > Object Display > No 
Geometry.

Show only an object’s bounding box. Select Display > Object Display > Bounding 
Box.

Related topics

Show or hide components

  Show or hide object-specific UI

  Show an isolated subset of objects or components in a panel
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Status line (toolbar)

Menu set menu

Menus and menu sets

Select tools and actions

File buttons

These buttons let you start a new scene file, open an existing scene file, or save the current 
scene file.

Create, open, or save a scene file

Selection mask

The Status Line (toolbar) contains several different controls to change the selection mask. The
selection mask determines what type of objects or components you can select.

The selection mode menu lets you select common preset selection masks.

The selection mode buttons let you switch between Select by hierarchy and combinations 
mode, Object mode, and Component mode.

The selection mask buttons let you make specific object/component types selectable or 
unselectable.

Selection, tools, and actions

Select objects or components

  Select only certain types of objects or components (selection masks)
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Selection options

Lock /unlock current selection

Click the lock to lock the selection so the left mouse button operates the manipulator 
instead of selecting. Click the lock again to unlock the selection.

Highlight Selection mode

When you are selecting components in any component mode, object selection is disabled, 
so that you can stay in component selection mode; for example, to select multiple 
components (vertices, faces, and so on). To override this setting, so that clicking on a 
non-component part of your object selects the entire object (putting you back in object 
mode), turn Highlight Selection off.

Select objects or components

Snapping buttons

Snap to grids

Snaps a vertex (CV or polygonal vertex) or pivot point to a grid corner. If you select Snap 
to grids before you create a curve, its vertices snap to the grid corners.

Snap to curves

Snaps a vertex (CV or polygonal vertex) or pivot point to a curve or curve on surface.

Snap to points

Snaps a vertex (CV or polygonal vertex) or pivot point to a point. This can include face 
centers.

Snap to view planes

Snaps a vertex (CV or polygonal vertex) or pivot point to a view plane.

Snap to the grid, a curve, points, or a view plane

  Snap all creation tools to a surface or construction plane

Make selected object live

Converts the selected surface to a live surface.

Modify > Make Live

Render buttons
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Click these buttons to open the Render View window, perform a normal render, perform an 
IPR render, or open the render settings window.

Input box

Use the Input box to quickly select, rename, or transform objects and components within the 
Maya scene without having the Channel Box displayed. Click the arrow to the left of the input 
fields to choose an Input mode; Absolute transform, Relative transform, Rename, or Select by
name. The default setting is Absolute transform. The Input mode is saved with your user 
preferences.

Input Mode How to use

Absolute transform

Type numbers in the X, Y, Z fields to move, scale, or 
rotate, based on the currently selected transformation 
tool. The objects or components are transformed with 
reference to their original creation position.

You can also enter a single value in one field (for example, 
X) without affecting the other transformation values.

Relative transform

Type numbers in the X, Y, Z fields to move, scale, or 
rotate based on the currently selected transformation tool. 
The objects or components are transformed with reference 
to their current position.

You can also enter a single value in one field (for example, 
X) without affecting the other transformation values.

Move, rotate, or scale objects and components

Rename

Edit the name of the currently selected object. When more 
than one object is selected, Maya increments a number at 
the end of the name for each object.

Change the name of one or more objects

Select by name
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Type the name of an object to select it. You can use 
wildcard characters (* and ?) to select multiple objects.

Select objects or components

Sidebar buttons

Click a button to show a sidebar:

Attribute Editor/notes

Settings for the current tool

Channel Box/Layer Editor
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Getting Started with Maya
> Maya Basics

>  Lesson 4:  Components and attributes

The Attribute Editor

The Attribute Editor provides information about the various nodes and attributes for the 
objects and materials in your scene. Like the Channel Box, you can view and edit the basic 
transform information and many other keyable attributes. However, the Attribute Editor 
provides a more detailed display of all attributes for a selected object.

To view object attributes using the Attribute Editor

In the scene view, select templeRoof so it becomes the selected object.1.

To view the Attribute Editor, click the Show/Hide icon on the Status Line.2.

The Attribute Editor displays the attributes for templeRoof. The various attributes for the 
templeRoof object appear under various tabs. Each tab represents a node.

Click the templeRoof tab to see its attributes.3.

This tab is known as the transform node, because the most important attributes on this
tab control templeRoof’s transformation. Every visible object in Maya has a transform
node, including cameras and lights.

Click the templeRoofShape tab to see its attributes.4.

This tab is called the shape node because the attributes establish the object’s geometric
shape or physical properties when the object is first created. Most objects have shape
nodes, some do not, such as the group for the column objects. The shape node also
includes other types of attributes, such as object display attributes.

Click the makeNurbSphere tab to see its attributes.5.

This is an input node that includes attributes related to the object’s construction history.
The attributes of an input node are passed to another node subsequent in the
construction history for the object—in this case, to the templeRoofShape node.

The last two nodes are initialShadingGroup and lambert1. If you can’t see them, click
the display arrow.

6.
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The initialShadingGroup and lambert1 nodes are default nodes that relate to the default 
shading material for an object. Maya uses them to establish the initial color of objects 
and other settings related to shading. If you create your own shading materials for the 
temple, as you will in the following steps, these nodes are replaced by the new shading 
nodes you create.
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Getting Started with Maya
> Maya Basics

>  Lesson 2:  Creating, manipulating, and viewing objects

The Channel Box

The Channel Box is an editing panel that provides you access to an object’s transformation
information and much more. It provides information on three distinct areas for any type of
object: The transform node, shape node, and input node.

Nodes are where information about object types are kept track of within Maya. Nodes are 
comprised of attributes. Attributes refer to information related to what the node is designed to
accomplish. In this case, information about the primitive cylinder’s Y axis rotation is referred
to as the Rotate Y attribute. You will learn more about nodes later in this tutorial.

When you moved and rotated the cylinder primitive using the Move Tool, you were doing this 
by your own visual judgement. This will usually be sufficient for many of your creative 
applications.

If you need to control the attribute of an object with more accuracy you can do this by 
entering the precise values into the appropriate attribute field of the Channel Box.

To move and rotate the base using the Channel Box

With the base cylinder selected, view the Transformation attributes in the Channel Box. 
Specifically, view the values for Translate Y, and Rotate Y.

1.

In the Channel Box, adjust the attribute values so they match the above image by 
clicking in the field and entering the correct numerical values.

2.

This accurately positions the base in your Maya scene.

Maya named the cylinder primitive when it was first created. Rename the cylinder to 
something more meaningful to your project.

To rename the cylinder primitive using the Channel Box

In the Channel Box, click in the field with the name pCylinder1.1.

Rename the primitive object by typing the new name: templeBase and then pressing 
Enter.

2.
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Getting Started with Maya
> Maya Basics

>  Lesson 3:  Viewing the Maya 3D scene

The Hypergraph

The Hypergraph is a window that shows how the nodes and their connections are organized in
your scene. You view object hierarchies and dependencies in the Hypergraph. Use the 
Hypergraph to view what happens when you group an object.

To view the Hypergraph

From the view menu, select Panels > Layouts > Two Panes Stacked.1.

The scene view splits into two viewing panels - each has their own separate view menu. 
You will set these to view the scene in the upper view and the Hypergraph in the other.

From the lower pane menu, select Panels > Hypergraph Panel > Hypergraph Hierarchy.2.

The Hypergraph panel will display below the scene view panel.

At the top of the Hypergraph panel, select the Scene Hierarchy icon to ensure the 
Hypergraph is displaying the scene hierarchy.

3.

In the Hypergraph panel, select View > Frame All.4.

The Hypergraph displays the hierarchy for all of the objects in the scene. This approach 
to viewing the entities in the scene provides a very graphical approach to viewing all of 
the various nodes in your scene.

In the Hypergraph, each node is represented as a rectangle labelled with an icon that 
denotes the type of information it represents (for example, surface, shading, and so 
on). Each node has a unique name assigned to it when it is first created. When you 
rename your objects, you are actually renaming the node associated with that object.

Some nodes display with a line connecting them. This denotes that they are in a 
hierarchy and have a dependency structure based on how they were originally grouped.

For the temple’s column objects, the hierarchy displays each of the named objects
under a node labelled group1. Group1 is the parent node for this hierarchy of objects.

In Maya, when the parent node (sometimes referred to as the root node) is moved, 
rotated, or scaled in any way, the child nodes (sometimes referred to as the leaf nodes) 
underneath are also affected.

When you select objects at the top level of a hierarchy and move them, the objects 
within the hierarchy or group follow.
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Note
This system of nodes, attributes, and hierarchies may initially appear somewhat complex, 
but it is one of the most powerful features of Maya. The node based architecture provides 
flexibility and power to create complex models, shaders, and animations.
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To rename the parent node in the Hypergraph

In the Hypergraph, click on the group1 node so it becomes active.1.

In the scene view, all of the objects in the column group become selected as a result of 
selecting the group at the top (parent) level of the hierarchy.

In the Hypergraph, right-click the top node representing group1 and select Rename 
from the pop-up menu.

2.

A small text box appears in the node.

Enter Column as the new name.3.

Now that the column is grouped, you need to position it at one corner of the temple base.

To position the column on the temple base

Change the display of objects to wireframe mode by tapping the 4 key on your 
keyboard.

1.

This is a keyboard shortcut. Instead of selecting the item from the menu you can use a 
single key to implement the command.

Tip
Many of the tools and features in Maya can be accessed using keyboard shortcuts. In 
Maya, these shortcuts are called Hotkeys. Some Hotkeys are displayed directly beside the 
menu item, others are listed in the Hotkey editor. For a complete listing of available 
hotkeys, go to Window > Settings/Preferences > Hotkeys.

In the Hypergraph, select the Column at the top node so that Column becomes active in
the scene view.

2.

In the scene view, use the Move Tool to position Column at the front corner of the 
temple base as shown below.

3.

With your first column in position, you can now create a copy of the column and position it on 
the adjacent corner of the base.

To create a duplicate copy of the column

With Column still selected in the Hypergraph, select Edit > Duplicate >  from the main
menu.

1.

The Duplicate Options window appears.

In the Duplicate Options window, select Edit > Reset settings and then set the following 
options:

2.

Number of Copies: 1
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Leave the other options at their default settings.

In the Duplicate Options window, click Duplicate.3.

The Hypergraph view updates to show an additional column object in the scene. The 
copy also takes on the prefix name of the original group and is now labelled Column1.

In the scene view it appears that nothing was actually duplicated. When an object is 
duplicated without any transformations the copy is positioned in the same position as 
the original. The two objects are on top of each other.

You need to move the column into position on the adjacent corner of the temple base.

To move the duplicate column into position on the base

In the Hypergraph, ensure Column1 is selected by clicking on its top node so it becomes
selected in the scene view.

1.

In the scene view, use the Move Tool to position Column1 on the adjacent corner of the 
temple base as shown below.

2.

From the Toolbox, click the Four View layout shortcut.3.

The workspace changes to a four view layout and the Hypergraph is no longer
displayed.
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Getting Started with Maya
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>  Lesson 1:  The Maya user interface

The Maya interface

Now that Maya is running, you first need to understand what you are seeing. There are a lot 
of items displayed in the Maya user interface.

The best way to begin is to learn the fundamental tools and then learn additional tools as you 
need them. Begin by learning some of the main tools.

The Maya workspace

The Maya workspace is where you conduct most of your work within Maya. The workspace is 
the central window where your objects and most editor panels appear.
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When you start Maya for the first time, the workspace displays by default in a perspective 
window, or panel. There are the other components of the default perspective view panel:

The panel is labeled persp at the bottom to indicate that you are viewing the Maya 
scene from a perspective camera view.

The panel has its own menu bar at the top left corner of the panel. These menus allow 
you to access tools and functions related to that specific panel.

The grid is displayed with two heavy lines intersecting at the center of the Maya scene. 
This central location is called the origin. The origin is the center of Maya’s 3D world, and
with all object’s directional values measured from this location.

In Maya, like many other 3D applications, the three dimensions are labeled as the X, Y, and Z 
axes. The origin is located at X, Y, Z position of 0, 0, 0. The grid also lies along the X, Z plane. 
We refer to this as a plane because you might visualize an imaginary, flat, two-dimensional 
square laying along this 3D position.

Maya labels the X, Y, and Z axes with a color scheme: red for X, green for Y, and blue for Z. 
Many tools that you use in Maya use this color scheme to indicate that you are accessing a 
particular item that relates to X, Y, and Z in some way.

The axis indicator shows in which direction, X, Y, or Z, you are viewing the Maya scene. The 
axis indicator is color coded in the red, green, and blue color scheme and appears in the lower
left corner of a view panel.

This is extremely useful if you are new to 3D, as many of the instructions in this manual and 
the Maya Help assume you know where you are viewing the scene in relation to the X, Y, Z
axes.

Main Menu bar

Tools and items are accessible from pull down menus located at the top of the user interface. 
In Maya, menus are grouped into menu sets. These menu sets are accessible from the Main 
Menu bar.

The Main Menu bar appears at the top of the Maya interface directly below the Maya title bar 
and displays the chosen menu set. Each menu set corresponds to a module within Maya: 
Animation, Polygons, Surfaces, Rendering, and Dynamics. Modules are a method for grouping 
related features and tools. Maya® UnlimitedTM has additional menu sets (For example,
Maya® nClothTM).
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You switch between menu sets by choosing the appropriate module from the menu selector on
the Status Line (located directly below the File and Edit menus). As you switch between menu 
sets, the right-hand portion of the menus change, but the left-hand portion remains the 
same; the left-hand menus are common menus to all menu sets. The left-hand menus contain
File, Edit, Modify, Create, Display, and Window.

To select a specific menu set

On the Status line, select Animation from the drop-down menu.1.

The Main Menu changes to display the menu set that relates to the Animation module. 
In particular, menu titles such as Animate, Deform, Skeleton, Skin, and so on, appear.

Using the menu selector, choose Polygons from the drop-down menu.2.

The main menu changes to display the menu set for Polygons. Menu titles such as 
Select, Mesh, Edit Mesh, and so on, appear.

For now, leave the menu set at Polygons. You will use this set in the next step.

To create a primitive 3D object from the Polygons menu set

From the Main Menu Bar, select Create > Polygon Primitives > Cube.1.

Maya creates a 3D cube primitive object and places it at the center (origin) of the Maya 
workspace.

Status Line

The Status Line, located directly below the Main Menu bar, contains a variety of items, most of
which are used while modeling or working with objects within Maya. Many of the Status Line 
items are represented by a graphical icon. The icons save space in the Maya interface and 
allow for quick access to tools used most often.
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In this lesson, you learn about some of the Status Line areas.

You’ve already learned the first item on the Status line: the Menu Selector used to select
between menu sets.

The second group of circled icons relate to the scene and are used to create, open, and save 
your Maya scenes.

The third and fourth group of buttons are used to control how you can select objects and 
components of objects. You will learn more about selection of objects in later lessons.

The fifth group of icons are used to control the Snap Mode for objects and components. You 
will begin to use these tools in a later lesson in this chapter.

The last section comprise three buttons that are used to show or hide editors, including the 
Attribute Editor, Channel Box, Layer Editor, and Tool Settings. The default display shows the 
Channel Box and the Layer Editor. When you create an object, like the cube for example, 
information about that object displays in these editors. You will learn how to use these editors 
later in this chapter.

For better organization on the Status Line, all of the icon buttons are broken into groups that 
you can expand and collapse, as shown.

Shelf

The Shelf is located directly below the Status line. The Maya Shelf is useful for storing tools 
and items that you use frequently or have customized for your own use. You can keep the 
tools and items you use most frequently in a location that provides handy access. Maya has 
some of the Shelf items pre-configured for your use.

To create an object using a tool from the Shelf

From the Shelf, select the Surfaces tab in order to view the tools located on that shelf.1.
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From the shelf, select the NURBS sphere icon located on the left end of the shelf by 
clicking on it.

2.

Maya creates a sphere primitive object and places it at the center of the Maya 
workspace in the same position as the cube.

Tip
You can determine if this is the correct tool prior to choosing it by first placing your 
mouse cursor over the icon, the name or description of it appears in a popup window 
directly over it.

In your scene view the wireframe outline of the cube you created earlier in the lesson has 
changed color to navy blue, and the sphere is displayed in a bright green color. The sphere is 
now the selected object and the cube is no longer selected. In Maya, when the object displays 
like this, we refer to it as being selected or active.

Selection of objects and components is a way of indicating to Maya that this particular item is 
to be affected by the tool or action you will subsequently choose. As you work with Maya, you 
will be selecting and deselecting items a lot. You will learn how to select and deselect objects 
later in this chapter.

Some numerical information appears in the Channel Box editor on the right hand side of the
user interface. This information relates to X, Y, and Z, translation, rotation, and scaling for the
active object. The X, Y, and Z Translate numerical values are currently set to 0. This indicates
that the sphere’s location is at the origin. The Channel Box is useful for viewing and editing
this type of basic information. You will use the Channel Box later in this chapter.
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To hide or show the Channel Box

To hide the Channel Box, click the Show/Hide Channel Box icon from the right end of 
the Status line.

1.

The Channel Box disappears, and the perspective scene view expands slightly. With the 
Channel Box hidden, you have more working area in your scene view.

To show the Channel Box, click the Show/Hide Channel Box icon on the Status line. The 
Channel Box appears in the scene view.

2.
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Getting Started with Maya
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>  Lesson 2:  Creating, manipulating, and viewing objects

The Toolbox: Layout shortcuts

The Toolbox is located on the left hand side of the Maya user interface. It contains icons that 
open tools for transforming your objects within Maya (selection, move, rotate, scale) as well 
as layout shortcuts for changing the views and panel layouts.

The Quick Layout buttons shortcuts allow you to select a different panel or switch to another 
layout.

You need to finish positioning the cylinder. To do this you need to see the object from a side 
view to make sure it is sitting exactly on the ground plane.

To change the panel layout to view the base from a side view

From the Toolbox, click the Four View layout shortcut.1.

The workspace changes to a four-view layout. The perspective view is located in the top 
right corner and the other views show the object from the top, front and side. The 
layout shortcuts have other options that you will learn later in this tutorial.

It is now possible to see the base from the side view, but it would be easier to 
determine the position of the base if the side view were enlarged to a full view.

To enlarge the side view, position the mouse cursor in the side view, and tap the 
spacebar of your keyboard.

2.

The workspace changes to a single view layout with the side view in an enlarged view. It
is easier to view the position of the base from this side view. Notice that the base lies 
slightly above and below the ground plane (X, Z).

Tip
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You can position your mouse cursor in any scene view and tap the spacebar once to 
toggle the view. If the view is a full panel view, it will change to a four panel view and 
vice versa.
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The Toolbox: Transformation tools

You need to move the base slightly upwards in the Y direction so it is positioned on the X, Z 
plane. To do this you use the Move transformation tool located in the Toolbox.

The upper half of the Toolbox contains the tools for transforming objects (selection, move, 
rotate, scale) within Maya. When you move your mouse cursor over any transformation tool 
icon you see the name of the tool appear next to the mouse cursor.

The tool’s name also appears in the Help Line at the bottom of the Maya window. The Help
Line has an additional purpose: it displays summary instructions as you use tools that require
several steps.

Selection and de-selection of objects

Before you can transform an object, you must ensure it is selected. You can select 
objects by clicking them directly, or by dragging a rectangular bounding box around 
some portion of the object to indicate what you want selected. To deselect an object, 
you simply click somewhere off of the selected object.

To select the base primitive object in the scene view

Do one of the following:

With your left mouse button, click the object’s wireframe outline in the scene view.

With your left mouse button, drag a bounding box around one corner or edge of the
object’s wireframe.

The object is selected when its wireframe outline color displays in a bright green color. 
If it is not selected, its display color is navy blue.

To use the Move Tool to adjust the position of the base
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Select the Move Tool from the Toolbox.1.

A move manipulator icon appears over the primitive cylinder in the scene view.

The Move Tool Manipulator has handles that point in the direction of the three 
fundamental axis directions of 3D space: X, Y, Z. The handles are colored red, green, 
and blue based on their function related to the X, Y, Z axes and control the direction of 
the movement along an axis.

When you click a specific handle, it indicates that the move is constrained to that 
particular axis direction.

In the side view, drag the green Y manipulator handle to move the primitive cylinder 
upwards in the Y direction. Move it upwards enough so that the bottom of the base 
cylinder is aligned with the X axis (the thick dark line of the grid)

2.

The base cylinder now needs to be rotated slightly so the front of the base is parallel to a grid 
line. Since each facet of the octagon represents 45 degrees of a circle, you need to rotate the 
object approximately half of that amount or 22.5 degrees.

To use the Rotate Tool to adjust the position of the base

Display all four views by positioning the mouse cursor in the view and tapping the 
spacebar of your keyboard.

1.

The four view panel appears.

Position the mouse cursor in the top view and tap the spacebar once.2.

The top view appears in the workspace.

With the base cylinder selected, choose the Rotate tool from the Toolbox.3.

A rotate manipulator icon appears over the primitive cylinder in the scene view.

The Rotate Tool manipulator consists of three rings (handles), plus a virtual sphere 
enclosed by the rings. The colors of the handles correspond to the X, Y, and Z axes. The
handles are colored red, green, and blue based on their function related to the X, Y, Z 
axes and control the direction of the rotation around an axis.

In the top view, drag the green Y manipulator ring to rotate the primitive cylinder so 
that one of the facets of the base cylinder is aligned with the grid as shown in the image
below.

4.

You are rotating the cylinder around its Y axis.
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You may be asking yourself the question “How do I know if I’ve rotated the base exactly
22.5 degrees?” You can check the accuracy of the rotation by viewing the Channel Box.
Rotate Y should be close to 22.5 degrees.

Tip
You can undo and redo the last action you performed. Undo reverses the last action you 
performed on a selected object. It also reverses any action you performed from the Edit 
Menu.
To undo an action select, Edit > Undo. Maya allows you to perform multiple undos.
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Basics

Tool and action hotkeys

Press Function

q Select Tool

w Move Tool

e Rotate Tool

r Scale Tool

t Show Manipulator Tool

 + t Universal Manipulator

y Last tool used

+

-

Change the size of the manipulator

Press Function

z Undo

 + z Redo

g Repeat last action

F8 Switch between object/component selection mode
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p Parent

 + p Unparent

s Set key

 + w Key the selected object position

 + e Key the selected object rotation

 + r Key the selected object scale

Press Function

8 Paint Effects panel

 + a Attribute Editor

Hold Function

x Snap to grid

c Snap to curve

v Snap to point

Related topics

Create or edit a marking menu

  Assign a predefined command to a hotkey

  View a list of all assigned hotkeys
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Basics

Transform along different axes

In the Move Tool and Rotate Tool, you can select what axes to use.

Move Tool

Object moves along an object’s own rotated axes.

Local moves along an object’s parent’s rotated axes.

World moves along the world (grid) axes.

Normal lets you move CVs on a NURBS surface along U, V, or Normal directions.

You can specify the movement axis of the Move Tool in four additional ways:

Move along live object axis

Orient the Move axis towards a point (Set to point).

Align the Move axis with an edge (Set to Edge).

Align the Move axis with a face (Set to Face).

Move along custom axis (Custom Axis orientation).

Move along live object axis

You can set the Move Tool to move objects along the axis of a live object. Most commonly, 
you would make a construction plane live, but any object can be set live.

Example: moving an object along the axis of a live object

Create a construction plane (Create > Construction Plane). 1.

Rotate the plane.2.

With the plane selected, click the Make the selected object live icon  in the Status 
Line, or select Modify > Make Live. 

3.

Create another shape (here, a polygon torus).4.

Do one of the following to open the Move Tool settings:5.

Double-click the Move Tool icon.

Select Modify > Transformation Tools > Move Tool > .

In the Move Settings section of the Move Tool options, change the Move setting to Along
Live Object Axis.

6.

The move arrows of the move tool align to the live construction plane.
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By clicking and dragging the move arrows, you can now move the torus in a constrained 
manner: along the surface in two directions or at exact right angles to the surface.

Clicking and dragging the center point of the move arrows moves the object with default
behavior (snap to live geometry). For more information, see “Modify > Make Live” and “Move 
Tool”.

The geometry of the live object doesn’t matter; the move aligns to the axes of the live object.

Orient the Move axis towards a point

You can set the Move Tool to move the selected object along a axis defined by selecting a
point.

Select an object.1.

Using the marking menus for the Move Tool (  + w), select Align Along and then 
Orient Axis Towards Point.

2.

Select a point in the scene. It can be a point on any object, including the currently 
selected object.

3.

The axis of the Move Tool changes.

You can see the new axis settings by opening the Move Tool settings (double-click the Move 
Tool icon or select Modify > Transformation Tools > Move Tool > ) and examining the three 
boxes under Custom Axis Orientation.

Align the Move axis with an edge or face

You can set the Move Tool to move the selected object along an axis defined by an edge or a 
face.

Select an object.1.

Using the marking menus for the Move Tool (  + w), select Align Along and then Align 2.
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Axis With Face or Align Axis With Face.

Select an edge or face in the scene. It can be an edge or face on any object, including 
the currently selected object.

3.

The axis of the Move Tool changes.

You can see the new axis settings by opening the Move Tool settings (double-click the Move 
Tool icon or select Modify > Transformation Tools > Move Tool > ) and examining the three 
boxes under Custom Axis Orientation.

Move along custom axis

You can set the Move Tool to move objects along a custom axis.

Do one of the following to open the Move Tool settings:1.

Double-click the Move Tool icon.

Select Modify > Transformation Tools > Move Tool > .

In the Move Settings section of the Move Tool settings, enter the x, y, and z offset of 
the custom axis in radians. 

2.

Rotate Tool

Local rotates around an object’s own axes.

Global rotates around the world (grid) axes. When this option is on the rings do not 
rotate with each other but instead stay locked to the world axes.

Gimbal changes only the X, Y, or Z rotation value. In local and global modes, the rings 
may change more than one of the rotation XYZ channels.

Related topics

Transformations

  World space, object space, and local space

Move Tool

  Rotate Tool
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Basics

Tumble, track, dolly, or tilt the view

To look around in a scene, you move the virtual camera associated with a view panel.

Hold Drag To...

Tumble

Track

or

Dolly

 + Draw a box around the part of the view you want to dolly in on.

If you drag the box out from left to right, you dolly in.

If you drag the box out from right to left, you dolly out.

These keyboard shortcuts actually correspond to tools. While it is much more convenient to 
use these keyboard shortcuts, you may occasionally want to use the tool form, or set the 
options for the tool:

View > Camera Tools > Tumble Tool

  View > Camera Tools > Track Tool

  View > Camera Tools > Dolly Tool

To roll (tilt) the camera
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In a view panel, select View > Camera Tools > Roll Tool.1.

Drag  to roll the camera.2.

To zoom the camera lens

In a view panel, select View > Camera Tools > Zoom Tool.1.

Drag  to zoom the camera lens.2.

Related topics

Use the mouse to control camera azimuth, elevation, yaw or pitch

  Return to previous views

View > Camera Tools > Zoom Tool

  View > Camera Tools > Roll Tool
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Basics

Use manipulators

The Move Tool, Rotate Tool, Scale Tool, and the Universal Manipulator show a manipulator on 
the selected objects. You move, rotate, or scale the objects by dragging handles on the 
manipulator.

Other tools and objects can also have manipulators. Usually these are the same manipulators 
(or combinations of the manipulators) used by the Move, Rotate, or Scale Tools.

For more details on the Universal Manipulator, see Use the Universal Manipulator.

Position manipulator

Drag an arrow to move along that axis.

Drag the center handle to move freely across the view plane.

Click a handle to make it active (yellow), then drag  anywhere in a view window to 
move along the active handle.

Hold  and drag  up and down or left and right to move in that direction.

In a perspective view, +click an arrow to switch the center handle to move across 
an axis plane.

+click the center handle to switch it back to moving across the view plane.

Rotation manipulator

Drag the rings to rotate around the different axes.

Drag the outer ring to rotate around the view axis.

Scale manipulator
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Drag a box to scale along that axis.

Drag the center box to scale uniformly in all directions.

Click a handle to make it active (yellow), then drag  anywhere in a view window to 
move along the active handle.

Hold  and drag  up and down or left and right to scale in that direction.

Combined move/rotate/scale manipulator

This manipulator combines the handles from the Position, rotation, and scale manipulators in 
one. The Move/Rotate/Scale Tool and Proportional Modification Tool use this manipulator.

When a move or scale handle is active, the axis rotation rings are hidden. Click the outer ring 
rotation ring to show all rotation handles.

Some tools add another handle projecting from the center of the manipulator. Clicking this 
handle switches the manipulator axes between world and local space.

Complex manipulators

Many objects/nodes have manipulators that let you control the attributes of the node. Often 
these manipulators are based on the position, rotation and scale manipulators, although some
objects and nodes (for example, the spotlight) use complex custom manipulators.

Partial curve manipulators

Some actions (such as Revolve) let you operate on only part of a curve using the Curve 
Range: Partial option.

When you show manipulators for an action with a partial curve, boundary handles appear on 
the curve that let you adjust what part of the curve is used.
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Related topics

Transformations

  World space, object space, and local space

Move, rotate, or scale objects and components
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Basics

Use the Universal Manipulator

The Universal Manipulator combines the functions of the Move Tool, Rotate Tool, and Scale 
Tool. You can also use it to enter precise values to scale and rotate your object directly in the 
scene view.

To show the Universal Manipulator, do one of the following before or after selecting an object:

 the Universal Manipulator icon  in the Toolbox.

Select Modify > Transformation Tools > Universal Manipulator. 

Press +t. 

The Universal Manipulator interface appears around the object.

The rotation arrows are color-coded based on what axis they are rotating around (red for the 
x-axis, green for the y-axis, and blue for the z-axis). A selected arrow is yellow.

Note
The Universal Manipulator does not work on components such as vertices, faces, and so 
on. To manipulate components, use the Move, Rotate, and Scale Tools.

To move your object along an axis

Drag one of the move handles.

A number appears in light blue showing the distance from the starting point of the move.

To move your object precisely along an axis

Select a move arrow.1.

A numerical entry text box appears.

Type a value and press Enter.2.

To move your object freely

Drag the center point of the manipulator arrows.

Vector lines in red, yellow, and blue and numbers in light blue appear, showing the distance 
from the starting point of the move.
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To rotate your object freely

Drag a rotation handle.

To rotate your object precisely

Select a rotation arrow.1.

A numerical entry text box appears.

Type a value in degrees and press Enter.2.

Note
The value entered is in degrees no matter what the setting is of your Working Units.

To scale your object proportionately

+drag a bounding box vertex.

Numbers appears showing the size of each dimension of the object.

This scales your object from the opposite corner of the bounding box. To scale from the center
of the bounding box,  +  + drag.

To scale one dimension of your object

Drag on a bounding box vertex.

Numbers appears showing the size of each dimension of the object.

This scales your object from the opposite corner of the bounding box. To scale one dimension 
of your object from the center of the bounding box,  + drag.

To scale your object precisely

Click a size number.1.

A numerical entry text box appears.

Type a value and press Enter.2.

To scale one dimension of your object precisely

click a size number.1.

A numerical entry text box appears.

Type a value and press Enter.2.
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Getting Started with Maya
> Polygonal Modeling

>  Lesson 1:  Modeling a polygonal mesh

Using 2D reference images

You can use front, side, and top views from drawings, sketches, or photographs to help 
visualize your 3D model in Maya, much like an architect or engineer creates their designs from
the plan and elevation views of a blueprint.

You can import 2D images into your orthographic camera views as image planes. An image 
plane is a 2D object (plane) that places an image file in the scene view. By default, an image 
plane only appears in the camera to which the image plane is connected. Image planes are 
also used to create backgrounds and environments when rendering.

When you load an image into an image plane, it appears in your selected orthographic view at
the origin along an axis that is perpendicular to the selected orthographic view. You can refer 
to the image in the orthographic view to define the silhouette and character lines of your 
model. You can move the image plane, change its transparency, or turn it off.

For this lesson you load two images we’ve provided for the lesson into image planes in the
front and side orthographic views of your scene. You’ll refer to them frequently while you
model the helmet.

To load reference images into the front and side orthographic views

In the Toolbox, click the Four View shortcut from the Layout Shortcuts bar.1.

The perspective view is located in the top right corner and the other views show your 
scene from the top, front, and side.

In the front view panel menu, select View > Image Plane > Import Image.2.

Select the image file named HelmetFront.jpg.3.

This image is on the Maya DVD in the following path: 
Tutorials_and_Extras/GettingStartedLessonData/PolygonModeling/sourceimages

In the browser, click the Open button.4.

HelmetFront.jpg appears in the front view and depicts a drawing of the helmet.

In the side view panel menu, select View > Image Plane > Import Image.5.
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Select the image file named HelmetSide.jpg.6.

This image is on the Maya DVD in the following path: 
Tutorials_and_Extras/GettingStartedLessonData/PolygonModeling/sourceimages

In the browser, click the Open button.7.

HelmetSide.jpg appears in the side view.

Note
The front and side images for this lesson were created so that the two views are aligned 
and the height of each image is same, so when you import them as image planes, they 
appear at the same scale. These are important considerations when you construct your 
own reference images in the future. Otherwise, your reference images may not align or 
be at different scales between the two orthographic views.

By referring to the image planes in the orthographic views as you work, you can
correlate how a feature in one view, appears in another. While a top view reference
image is useful in many cases, it isn’t critical for this lesson.

The image planes can be set so they appear partially transparent to allow you to work
with the polygonal components more easily. To do this you’ll select the front and side
orthographic cameras and modify the transparency of the images.

To modify the transparency of the reference images

In the front view panel menu, select View > Select Camera.1.

The camera for the front orthographic view is selected.

Display the Channel Box by clicking the Show/Hide Channel Box icon on the Status Line.2.

The Channel Box displays the keyable attributes for the Front orthographic camera.

In the Inputs section, click the ImagePlane1 name to display the attributes for the 
image plane.

3.

Set the Alpha Gain attribute to a value of 0.25.4.

The image appears partially transparent.

In the side view panel menu, select the camera and change the Alpha Gain setting for 
the side view image plane exactly as you changed the front view image plane.

5.

Tip
You can change the Alpha Gain at any time if you want the image planes to appear more 
or less transparent.
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In the perspective view’s panel menu, select Show > Cameras to temporarily turn off
the display of the image planes in the perspective view.

6.
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Basics

World space, object space, and local space

3D positions and transformations exist within coordinate systems called spaces.

World space is the coordinate system for the entire scene. Its origin is at the center of the 
scene. The grid you see in view windows shows the world space axes.

Object space is the coordinate system from an object’s point of view. The origin of object
space is at the object’s pivot point, and its axes are rotated with the object.

Local space is similar to object space, however it uses the origin and axes of the object’s
parent node in the hierarchy of objects. This is useful when you haven’t transformed the
object itself, but it is part of a group that is transformed.

Related topics

Transformations

  The pivot point
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